Re: [PATCH v2 net-next 3/4] net: introduce common dev_page_is_reserved()

From: John Hubbard
Date: Sat Jan 30 2021 - 16:25:21 EST



On 1/30/21 11:45 AM, Alexander Lobakin wrote:
From: Jakub Kicinski <kuba@xxxxxxxxxx>
Date: Sat, 30 Jan 2021 11:07:07 -0800

On Sat, 30 Jan 2021 15:42:29 +0000 Alexander Lobakin wrote:
On Wed, 27 Jan 2021 20:11:23 +0000 Alexander Lobakin wrote:
+ * dev_page_is_reserved - check whether a page can be reused for network Rx
+ * @page: the page to test
+ *
+ * A page shouldn't be considered for reusing/recycling if it was allocated
+ * under memory pressure or at a distant memory node.
+ *
+ * Returns true if this page should be returned to page allocator, false
+ * otherwise.
+ */
+static inline bool dev_page_is_reserved(const struct page *page)

Am I the only one who feels like "reusable" is a better term than
"reserved".

I thought about it, but this will need to inverse the conditions in
most of the drivers. I decided to keep it as it is.
I can redo if "reusable" is preferred.

Naming is hard. As long as the condition is not a double negative it
reads fine to me, but that's probably personal preference.
The thing that doesn't sit well is the fact that there is nothing
"reserved" about a page from another NUMA node.. But again, if nobody
+1s this it's whatever...

Agree on NUMA and naming. I'm a bit surprised that 95% of drivers
have this helper called "reserved" (one of the reasons why I finished
with this variant).
Let's say, if anybody else will vote for "reusable", I'll pick it for
v3.

Definitely "reusable" seems better to me, and especially anything *other*
than "reserved" is a good idea, IMHO.


thanks,
--
John Hubbard
NVIDIA