Re: [PATCH v1 1/2] s390/kvm: split kvm_s390_real_to_abs

From: David Hildenbrand
Date: Mon Mar 22 2021 - 07:23:35 EST


On 22.03.21 12:16, David Hildenbrand wrote:
On 22.03.21 12:12, Heiko Carstens wrote:
On Mon, Mar 22, 2021 at 10:53:46AM +0100, David Hildenbrand wrote:
diff --git a/arch/s390/kvm/gaccess.h b/arch/s390/kvm/gaccess.h
index daba10f76936..7c72a5e3449f 100644
--- a/arch/s390/kvm/gaccess.h
+++ b/arch/s390/kvm/gaccess.h
@@ -18,17 +18,14 @@
/**
* kvm_s390_real_to_abs - convert guest real address to guest absolute address
- * @vcpu - guest virtual cpu
+ * @prefix - guest prefix
* @gra - guest real address
*
* Returns the guest absolute address that corresponds to the passed guest real
- * address @gra of a virtual guest cpu by applying its prefix.
+ * address @gra of by applying the given prefix.
*/
-static inline unsigned long kvm_s390_real_to_abs(struct kvm_vcpu *vcpu,
- unsigned long gra)
+static inline unsigned long _kvm_s390_real_to_abs(u32 prefix, unsigned long gra)

<bikeshedding>
Just a matter of taste, but maybe this could be named differently?
kvm_s390_real2abs_prefix() ? kvm_s390_prefix_real_to_abs()?
</bikeshedding>

+1, I also dislike these "_.*" style functions here.

Yes, let's bikeshed then :)

Could you then please try to rename page_to* and everything that looks
similar to page2* please? I'm wondering what the response will be..

Oh, we're bikeshedding about anything now? Cool.

(I agree that real2abs is not such a good idea ;) )

--
Thanks,

David / dhildenb