Re: [PATCH 2/3] cpumask: Introduce DYING mask

From: Steven Rostedt
Date: Mon Mar 22 2021 - 11:08:55 EST


On Sun, 21 Mar 2021 19:30:37 +0000
Qais Yousef <qais.yousef@xxxxxxx> wrote:

> On 03/10/21 15:53, Peter Zijlstra wrote:
> > --- a/kernel/cpu.c
> > +++ b/kernel/cpu.c
> > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne
> > int (*cb)(unsigned int cpu);
> > int ret, cnt;
> >
> > + if (bringup != !cpu_dying(cpu))
>
> nit: this condition is hard to read

Would
if (bringup == !!cpu_dying(cpu))

read better?

-- Steve

>
> > + set_cpu_dying(cpu, !bringup);