Re: [PATCH v1 3/3] mux: gpio: Simplify code by using dev_err_probe()

From: Peter Rosin
Date: Tue Mar 30 2021 - 12:13:46 EST


Hi!

On 2021-03-26 18:24, Andy Shevchenko wrote:
> Use already prepared dev_err_probe() introduced by the commit
> a787e5400a1c ("driver core: add device probe log helper").
> It simplifies EPROBE_DEFER handling.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
> drivers/mux/gpio.c | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/mux/gpio.c b/drivers/mux/gpio.c
> index e5ef9284e2b4..c3036bfffd50 100644
> --- a/drivers/mux/gpio.c
> +++ b/drivers/mux/gpio.c
> @@ -65,12 +65,8 @@ static int mux_gpio_probe(struct platform_device *pdev)
> mux_chip->ops = &mux_gpio_ops;
>
> mux_gpio->gpios = devm_gpiod_get_array(dev, "mux", GPIOD_OUT_LOW);
> - if (IS_ERR(mux_gpio->gpios)) {
> - ret = PTR_ERR(mux_gpio->gpios);
> - if (ret != -EPROBE_DEFER)
> - dev_err(dev, "failed to get gpios\n");
> - return ret;
> - }
> + if (IS_ERR(mux_gpio->gpios))
> + return dev_err_probe(dev, PTR_ERR(mux_gpio->gpios), "failed to get gpios\n");

Please break this line, keeping it as one line does not significantly
increase readability. I know many people think long lines are super
nice, but I'm not sold and am stubbornly sticking to 80 cols. I'd rater
have room for one more window instead of wasting loads of screen on
mostly short lines and a long one here and there. Sorry to be a pest,
but coding-style.rst agrees with me:

"The preferred limit on the length of a single line is 80 columns."

So, with that changed,

Acked-by: Peter Rosin <peda@xxxxxxxxxx>

Cheers,
Peter

> WARN_ON(pins != mux_gpio->gpios->ndescs);
> mux_chip->mux->states = BIT(pins);
>
>