Re: [PATCH v7 3/8] mm/rmap: Split try_to_munlock from try_to_unmap

From: Alistair Popple
Date: Tue Mar 30 2021 - 18:10:47 EST


On Wednesday, 31 March 2021 5:49:03 AM AEDT Jason Gunthorpe wrote:
> On Fri, Mar 26, 2021 at 11:08:00AM +1100, Alistair Popple wrote:
>
> > +static bool try_to_munlock_one(struct page *page, struct vm_area_struct
*vma,
> > + unsigned long address, void *arg)
> > +{
>
> Is this function name right?

Perhaps. This is called from try_to_munlock() hence the name, but see below
for some commentary on that naming.

> > + struct page_vma_mapped_walk pvmw = {
> > + .page = page,
> > + .vma = vma,
> > + .address = address,
> > + };
> > +
> > + /* munlock has nothing to gain from examining un-locked vmas */
> > + if (!(vma->vm_flags & VM_LOCKED))
> > + return true;
> > +
> > + while (page_vma_mapped_walk(&pvmw)) {
> > + /* PTE-mapped THP are never mlocked */
> > + if (!PageTransCompound(page)) {
> > + /*
> > + * Holding pte lock, we do *not* need
> > + * mmap_lock here
> > + */
> > + mlock_vma_page(page);
>
> Because the only action this function seems to take is to call
> *mlock*_vma_page()
>
> > + }
> > + page_vma_mapped_walk_done(&pvmw);
> > +
> > + /* found a mlocked page, no point continuing munlock check */
> > + return false;
> > + }
> > +
> > + return true;
> > +}
> > +
> > /**
> > * try_to_munlock - try to munlock a page
> > * @page: the page to be munlocked
> > @@ -1796,8 +1821,7 @@ bool try_to_unmap(struct page *page, enum ttu_flags
flags)
> > void try_to_munlock(struct page *page)
> > {
>
> But this is also called try_to_munlock ??

As far as I can tell this has always been called try_to_munlock() even though
it appears to do the opposite.

> /**
> * try_to_munlock - try to munlock a page
> * @page: the page to be munlocked
> *
> * Called from munlock code. Checks all of the VMAs mapping the page
> * to make sure nobody else has this page mlocked. The page will be
> * returned with PG_mlocked cleared if no other vmas have it mlocked.
> */

In other words it sets PG_mlocked if one or more vmas has it mlocked. So
try_to_mlock() might be a better name, except that seems to have the potential
for confusion as well because it's only called from the munlock code path and
never for mlock.

> So what clears PG_mlocked on this call path?

See munlock_vma_page(). munlock works by clearing PG_mlocked, then calling
try_to_munlock to check if any VMAs still need it locked in which case
PG_mlocked gets set again. There are no other callers of try_to_munlock().

> Something needs attention here..

I think the code is correct, but perhaps the naming could be better. Would be
interested hearing any thoughts on renaming try_to_munlock() to try_to_mlock()
as the current name appears based on the context it is called from (munlock)
rather than what it does (mlock).

- Alistair

> Jason
>