Re: [PATCH] pci: Rename pci_dev->untrusted to pci_dev->external
From: Christoph Hellwig
Date: Tue Apr 20 2021 - 02:11:30 EST
On Mon, Apr 19, 2021 at 05:30:49PM -0700, Rajat Jain wrote:
> The current flag name "untrusted" is not correct as it is populated
> using the firmware property "external-facing" for the parent ports. In
> other words, the firmware only says which ports are external facing, so
> the field really identifies the devices as external (vs internal).
> Only field renaming. No functional change intended.
I don't think this is a good idea. First the field should have been
added to the generic struct device as requested multiple times before.
Right now this requires horrible hacks in the IOMMU code to get at the
pci_dev, and also doesn't scale to various other potential users.
Second the untrusted is objectively a better name. Because untrusted
is how we treat the device, which is what mattes. External is just
how we come to that conclusion.