[PATCH v2] block: fix userspace documentation reference for del_gendisk()

From: Luis Chamberlain
Date: Mon Apr 26 2021 - 14:50:48 EST


Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
helpers") has a typo where it references drivers for del_gendisk() when we
instead meant userspace, as the reference is to the userspace experience.
This fixes this.

Signed-off-by: Luis Chamberlain <mcgrof@xxxxxxxxxx>
---
block/genhd.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/block/genhd.c b/block/genhd.c
index 39ca97b0edc6..e077adfcd1a2 100644
--- a/block/genhd.c
+++ b/block/genhd.c
@@ -594,8 +594,8 @@ EXPORT_SYMBOL(device_add_disk_no_queue_reg);
* with put_disk(), which should be called after del_gendisk(), if
* __device_add_disk() was used.
*
- * Drivers exist which depend on the release of the gendisk to be synchronous,
- * it should not be deferred.
+ * Userspace software may depend on the release of the gendisk to be
+ * synchronous, it should not be deferred.
*
* Context: can sleep
*/
--
2.29.2