Re: [PATCH] soc: amlogic: meson-ee-pwrc: Rename "get_power" to "is_powered_off"
From: Kevin Hilman
Date: Mon May 17 2021 - 16:54:25 EST
Martin Blumenstingl <martin.blumenstingl@xxxxxxxxxxxxxx> writes:
> The name "get_power" is used within the Meson EE power controller driver
> to indicate whether a power domain is turned on or off. With the
> original "get_power" naming the result was:
> - true = powered off
> - false = powered on
> Rename "get_power" to "is_powered_off" to make the naming consistent
> with the third argument to pm_genpd_init. Also this naming is easier to
> understand when reading the code without looking at the implementation
> of "get_power".
> Signed-off-by: Martin Blumenstingl <martin.blumenstingl@xxxxxxxxxxxxxx>
Reviewed-by: Kevin Hilman <khilman@xxxxxxxxxxxx>