Re: [PATCH v8 1/8] mm: Remove special swap entry functions

From: Peter Xu
Date: Tue May 18 2021 - 10:17:18 EST

On Tue, May 18, 2021 at 09:58:09PM +1000, Alistair Popple wrote:
> On Tuesday, 18 May 2021 12:17:32 PM AEST Peter Xu wrote:
> > On Wed, Apr 07, 2021 at 06:42:31PM +1000, Alistair Popple wrote:
> > > +static inline struct page *pfn_swap_entry_to_page(swp_entry_t entry)
> > > +{
> > > + struct page *p = pfn_to_page(swp_offset(entry));
> > > +
> > > + /*
> > > + * Any use of migration entries may only occur while the
> > > + * corresponding page is locked
> > > + */
> > > + BUG_ON(is_migration_entry(entry) && !PageLocked(p));
> > > +
> > > + return p;
> > > +}
> >
> > Would swap_pfn_entry_to_page() be slightly better?
> >
> > The thing is it's very easy to read pfn_*() as a function to take a pfn as
> > parameter...
> >
> > Since I'm also recently working on some swap-related new ptes [1], I'm
> > thinking whether we could name these swap entries as "swap XXX entries".
> > Say, "swap hwpoison entry", "swap pfn entry" (which is a superset of "swap
> > migration entry", "swap device exclusive entry", ...). That's where I came
> > with the above swap_pfn_entry_to_page(), then below will be naturally
> > is_swap_pfn_entry().
> Equally though "hwpoison swap entry", "pfn swap entry", "migration swap
> entry", etc. also makes sense (at least to me), but does that not fit in as
> well with your series? I haven't looked too deeply at your series but have
> been meaning to so thanks for the pointer.

Yeah it looks good too. It's just to avoid starting with "pfn_" I guess, so at
least we know that's something related to swap not one specific pfn.

I found the naming is important as e.g. in my series I introduced another idea
called "swap special pte" or "special swap pte" (yeah so indeed my naming is
not that coherent as well... :), then I noticed if without a good naming I'm
afraid we can get lost easier.

I have a description here in the commit message re the new swap special pte:

In which the uffd-wp marker pte will be the first swap special pte. Feel free
to ignore the details too, just want to mention some context, while it should
be orthogonal to this series.

I think yet-another swap entry suites for my case too but it'll be a waste as
in that pte I don't need to keep pfn information, but only a marker (one single
bit would suffice), so I chose one single pte value (one for each arch, I only
defined that on x86 in my series which is a special pte with only one bit set)
to not pollute the swap entry address spaces.

> > No strong opinion as this is already a v8 series (and sorry to chim in this
> > late), just to raise this up.
> No worries, it's good timing as I was about to send a v9 which was just a
> rebase anyway. I am hoping to try and get this accepted for the next merge
> window but I will wait before sending v9 to see if anyone else has thoughts on
> the naming here.
> I don't have a particularly strong opinion either, and your justification is
> more thought than I gave to naming these originally so am happy to rename if
> it's more readable or fits better with your series.

I'll leave the decision to you, especially in case you still prefer the old
naming. Or feel free to wait too until someone else shares the thoughts so as
to avoid unnecessary rebase work.


Peter Xu