Re: [PATCH v2 1/1] gpiolib: Introduce for_each_gpio_desc_if() macro
From: Andy Shevchenko
Date: Thu May 20 2021 - 04:15:51 EST
On Thu, May 20, 2021 at 11:07 AM Johan Hovold <johan@xxxxxxxxxx> wrote:
> On Tue, May 18, 2021 at 11:33:39AM +0300, Andy Shevchenko wrote:
Thank you for the response, my answer below.
> The _if suffix here is too vague.
> Please use a more descriptive name so that you don't need to look at the
> implementation to understand what the macro does.
> Perhaps call it
Haha, I have the same in my internal tree, but then I have changed to
_if and here is why:
- the API is solely for internal use (note, internals of struct
gpio_desc available for the same set of users)
- the current users do only same pattern
- I don't expect that we will have this to be anything else in the future
Thus, _if is a good balance between scope of use and naming.
I prefer to leave it as is.
> or just add the more generic macro
> and open-code the test so that it's clear what's going on here.
With Best Regards,