Re: [PATCH -next] mm/dmapool: use DEVICE_ATTR_RO macro

From: YueHaibing
Date: Mon May 24 2021 - 07:25:47 EST


On 2021/5/24 18:45, Andy Shevchenko wrote:
> On Sun, May 23, 2021 at 02:46:26PM +0800, YueHaibing wrote:
>> Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
>> which makes the code a bit shorter and easier to read.
>
> DEVICE_ATTR_RO()
> DEVICE_ATTR()
>
> After addressing above and below,
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>

Ok, will send v2.
>
>> Signed-off-by: YueHaibing <yuehaibing@xxxxxxxxxx>
>> ---
>> mm/dmapool.c | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/mm/dmapool.c b/mm/dmapool.c
>> index 16483f86360e..62083ef04878 100644
>> --- a/mm/dmapool.c
>> +++ b/mm/dmapool.c
>> @@ -62,8 +62,8 @@ struct dma_page { /* cacheable header for 'allocation' bytes */
>> static DEFINE_MUTEX(pools_lock);
>> static DEFINE_MUTEX(pools_reg_lock);
>>
>> -static ssize_t
>> -show_pools(struct device *dev, struct device_attribute *attr, char *buf)
>> +static ssize_t pools_show(struct device *dev,
>> + struct device_attribute *attr, char *buf)
>> {
>> unsigned temp;
>> unsigned size;
>
> Unrelated change.

There change show_pools() to pools_show()

>
>> @@ -103,7 +103,7 @@ show_pools(struct device *dev, struct device_attribute *attr, char *buf)
>> return PAGE_SIZE - size;
>> }
>>
>> -static DEVICE_ATTR(pools, 0444, show_pools, NULL);
>> +static DEVICE_ATTR_RO(pools);
>>
>> /**
>> * dma_pool_create - Creates a pool of consistent memory blocks, for dma.
>> --
>> 2.17.1
>>
>