[PATCH 1/8] rtc: x1205: use DEVICE_ATTR_RO macro

From: Zhen Lei
Date: Wed Jun 02 2021 - 03:39:45 EST


Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes
the code a bit shorter and easier to read.

Signed-off-by: Zhen Lei <thunder.leizhen@xxxxxxxxxx>
---
drivers/rtc/rtc-x1205.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/rtc/rtc-x1205.c b/drivers/rtc/rtc-x1205.c
index d1d5a44d9122ad9..351e4725a7a5439 100644
--- a/drivers/rtc/rtc-x1205.c
+++ b/drivers/rtc/rtc-x1205.c
@@ -566,8 +566,8 @@ static const struct rtc_class_ops x1205_rtc_ops = {
.set_alarm = x1205_rtc_set_alarm,
};

-static ssize_t x1205_sysfs_show_atrim(struct device *dev,
- struct device_attribute *attr, char *buf)
+static ssize_t atrim_show(struct device *dev,
+ struct device_attribute *attr, char *buf)
{
int err, atrim;

@@ -577,10 +577,10 @@ static ssize_t x1205_sysfs_show_atrim(struct device *dev,

return sprintf(buf, "%d.%02d pF\n", atrim / 1000, atrim % 1000);
}
-static DEVICE_ATTR(atrim, S_IRUGO, x1205_sysfs_show_atrim, NULL);
+static DEVICE_ATTR_RO(atrim);

-static ssize_t x1205_sysfs_show_dtrim(struct device *dev,
- struct device_attribute *attr, char *buf)
+static ssize_t dtrim_show(struct device *dev,
+ struct device_attribute *attr, char *buf)
{
int err, dtrim;

@@ -590,7 +590,7 @@ static ssize_t x1205_sysfs_show_dtrim(struct device *dev,

return sprintf(buf, "%d ppm\n", dtrim);
}
-static DEVICE_ATTR(dtrim, S_IRUGO, x1205_sysfs_show_dtrim, NULL);
+static DEVICE_ATTR_RO(dtrim);

static int x1205_sysfs_register(struct device *dev)
{
--
2.26.0.106.g9fadedd