Re: [RFC v2-fix-v2 1/1] x86: Introduce generic protected guest abstractionn
From: Borislav Petkov
Date: Sat Jun 05 2021 - 16:12:11 EST
On Sat, Jun 05, 2021 at 11:12:57AM -0700, Kuppuswamy, Sathyanarayanan wrote:
> cc_has() or protected_guest_has() or prot_guest_has() or protected_boot_has()
Even if I still think it is not optimal, prot_guest_has() seems to be
best what we have because protected_guest_has() together with the flag
will become just too long to scan at a quick glance. And if you have to
do two tests, you'd have to break the line.
> For flag prefix either PR_GUEST_* or CC_*
PR_GUEST_* sounds ok to me.
The "cc" prefix stuff is nice and short but it doesn't say what it means
because it is simply too short. And code readability is very important.
Still open for better suggestions though.