Re: [PATCH RFCv4 4/4] lib/test_printf.c: add test cases for '%pD'

From: Petr Mladek
Date: Thu Jun 17 2021 - 10:53:41 EST


On Tue 2021-06-15 23:47:29, Andy Shevchenko wrote:
> On Tue, Jun 15, 2021 at 6:55 PM Jia He <justin.he@xxxxxxx> wrote:
> >
> > After the behaviour of specifier '%pD' is changed to print full path
> > of struct file, the related test cases are also updated.
> >
> > Given the string of '%pD' is prepended from the end of the buffer, the
> > check of "wrote beyond the nul-terminator" should be skipped.
> >
> > Signed-off-by: Jia He <justin.he@xxxxxxx>
> > ---
> > lib/test_printf.c | 26 +++++++++++++++++++++++++-
> > 1 file changed, 25 insertions(+), 1 deletion(-)
> >
> > diff --git a/lib/test_printf.c b/lib/test_printf.c
> > index d1d2f898ebae..9f851a82b3af 100644
> > --- a/lib/test_printf.c
> > +++ b/lib/test_printf.c
> > @@ -78,7 +80,7 @@ do_test(int bufsize, const char *expect, int elen,
> > return 1;
> > }
> >
> > - if (memchr_inv(test_buffer + written + 1, FILL_CHAR, bufsize - (written + 1))) {
>
> > + if (!is_prepended_buf && memchr_inv(test_buffer + written + 1, FILL_CHAR, bufsize - (written + 1))) {
>
> Can it be parametrized? I don't like the custom test case being
> involved here like this.

Yup, it would be nice.

Also it is far from obvious what @is_prepended_buf means if you do not
have context of this patchset. I think about a more generic name
that comes from the wording used in 3rd patch, e.g.

@need_scratch_space or @using_scratch_space or @dirty_buf

Anyway, the most easy way to pass this as a parameter would be to add it
to __test() and define a wrapper, .e.g:

static void __printf(3, 4) __init
__test(const char *expect, int elen, bool using_scratch_space,
const char *fmt, ...)

/*
* More relaxed test for non-standard formats that are using the provided buffer
* as a scratch space and write beyond the trailing '\0'.
*/
#define test_using_scratch_space(expect, fmt, ...) \
__test(expect, strlen(expect), true, fmt, ##__VA_ARGS__)


Best Regards,
Petr