Re: [PATCH 8/8] membarrier: Rewrite sync_core_before_usermode() and improve documentation

From: Andy Lutomirski
Date: Thu Jun 17 2021 - 20:12:19 EST

On 6/17/21 7:47 AM, Mathieu Desnoyers wrote:

> Please change back this #ifndef / #else / #endif within function for
> ...
> } else {
> ...
> }
> I don't think mixing up preprocessor and code logic makes it more readable.

I agree, but I don't know how to make the result work well.
membarrier_sync_core_before_usermode() isn't defined in the !IS_ENABLED
case, so either I need to fake up a definition or use #ifdef.

If I faked up a definition, I would want to assert, at build time, that
it isn't called. I don't think we can do:

static void membarrier_sync_core_before_usermode()