Re: [v2 1/8] dt-bindings: iio: adc: rename the aspeed adc yaml
From: Billy Tsai
Date: Mon Jul 26 2021 - 02:53:13 EST
On 2021/7/23, 10:45 PM, "Jonathan Cameron" <Jonathan.Cameron@xxxxxxxxxx> wrote:
On Fri, 23 Jul 2021 16:16:14 +0800
Billy Tsai <billy_tsai@xxxxxxxxxxxxxx> wrote:
> > The aspeed,ast2400-adc.yaml not only descriptor the bindings of ast2400.
> > Rename it to aspeed,adc.yaml for all of the aspeed adc bindings.
> > Signed-off-by: Billy Tsai <billy_tsai@xxxxxxxxxxxxxx>
> We try to avoid 'wild' card type namings most of the time and instead
> name after a particular part number. I say try because clearly
> we let a few in over the years :(
> It is very hard to know if this binding will apply to 'all' future
> aspeed ADCs.
> As such I'm not sure this particular rename makes sense.
If I want to extend the yaml file to compatible more versions of the aspeed adc.
Would you suggest to add new files call aspeed,ast2600-adc.yaml or just append it
to the aspeed,ast2400-adc.yaml?