Re: [PATCH 01/11] mm: Introduce a function to check for virtualization protection features

From: Christoph Hellwig
Date: Wed Jul 28 2021 - 09:19:19 EST


On Tue, Jul 27, 2021 at 05:26:04PM -0500, Tom Lendacky via iommu wrote:
> In prep for other protected virtualization technologies, introduce a
> generic helper function, prot_guest_has(), that can be used to check
> for specific protection attributes, like memory encryption. This is
> intended to eliminate having to add multiple technology-specific checks
> to the code (e.g. if (sev_active() || tdx_active())).

So common checks obviously make sense, but I really hate the stupid
multiplexer. Having one well-documented helper per feature is much
easier to follow.

> +#define PATTR_MEM_ENCRYPT 0 /* Encrypted memory */
> +#define PATTR_HOST_MEM_ENCRYPT 1 /* Host encrypted memory */
> +#define PATTR_GUEST_MEM_ENCRYPT 2 /* Guest encrypted memory */
> +#define PATTR_GUEST_PROT_STATE 3 /* Guest encrypted state */

The kerneldoc comments on these individual helpers will give you plenty
of space to properly document what they indicate and what a (potential)
caller should do based on them. Something the above comments completely
fail to.