Re: [GIT PULL 1/2] asm-generic: rework PCI I/O space access

From: John Garry
Date: Tue Aug 03 2021 - 07:24:25 EST


Anyway, one thing I mentioned earlier was that we could solve the
problem of drivers accessing unmapped IO ports and crashing systems on
archs which define PCI_IOBASE by building them under some "native port
IO support" flag.
Right, that was part of the goal here.

Great


One example of such a driver was F71805F sensor. You put that under
HAS_IOPORT, which would be available for all archs, I think. But I could
not see where config LEGACY_PCI is introduced. Could we further refine
that config to not build for such archs as arm64?

BTW, I think that the PPC dependency was added there to stop building
for power for that same reason, so hopefully we get rid of that.
Good point. It seems that I actually never added the LEGACY_PCI option
to my patch,

ok, it would be nice to see that.

so I'm just not building those drivers any more, and not
defining the inb()/outb() helpers either, causing a build failure when I'm
missing an option.

However it sounds like you are interested in a third option here, which
brings us to:

LEGACY_PCI: any PCI driver that uses inb()/outb() or is only available
on old-style PCI but not PCIe hardware without a bridge.
To be disabled for most architectures and possibly distros but can
be enabled for kernels that want to use those devices, as long as
CONFIG_HAS_IOPORT is set by the architecture.

HAS_IOPORT: not a legacy PCI device, but can only be built on
architectures that define inb()/outb(). To be disabled for s390
and any other machine that has no useful definition of those
functions.

That seems reasonable. And asm-generic io.h should be ifdef'ed by HAS_IOPORT. In your patch you had it under CONFIG_IOPORT - was that intentional?

On another point, I noticed SCSI driver AHA152x depends on ISA, but is not an isa driver - however it does use port IO. Would such dependencies need to be changed to depend on HAS_IOPORT?

I did notice that arm32 support CONFIG_ISA - not sure why.


HARDCODED_IOPORT: (or another name you might think of,) Used by
drivers that unconditionally do inb()/outb() without checking the
validity of the address using firmware or other methods first.
depends on HAS_IOPORT and possibly architecture specific
settings.

Yeah, that sounds the same as what I was thinking. Maybe IOPORT_NATIVE could work as a name. I would think that only x86/ia64 would define it. A concern though is that someone could argue that is a functional dependency, rather than just a build dependency.

Thanks,
John