Re: [PATCH 3/3] mm/gup: refactor and simplify try_get_page()

From: John Hubbard
Date: Mon Aug 09 2021 - 02:37:01 EST


On 8/8/21 11:29 PM, Christoph Hellwig wrote:
On Sun, Aug 08, 2021 at 04:50:18PM -0700, John Hubbard wrote:
+/*
+ * This has the same functionality as try_get_compound_head(), just with a
+ * slightly different API.
+ */
static inline __must_check bool try_get_page(struct page *page)
{
+ return try_get_compound_head(page, 1) != NULL;

What about removing try_get_page entirely instead?


This thought admittedly crossed my mind, but I was worried maybe I was
getting carried away with cleanups. But now that at least one other
person thinks that's reasonable, I'll be glad to cleanup the callers
too.

thanks,
--
John Hubbard
NVIDIA