Re: [PATCH v4 2/2] tpm: ibmvtpm: Rename tpm_process_cmd to tpm_status and define flag

From: Stefan Berger
Date: Tue Aug 10 2021 - 21:51:03 EST

On 8/10/21 1:58 PM, Jarkko Sakkinen wrote:
On Mon, Aug 09, 2021 at 03:21:59PM -0400, Stefan Berger wrote:
From: Stefan Berger <stefanb@xxxxxxxxxxxxx>

Rename the field tpm_processing_cmd to tpm_status in ibmvtpm_dev and set
the TPM_STATUS_BUSY flag while the vTPM is busy processing a command.

diff --git a/drivers/char/tpm/tpm_ibmvtpm.h b/drivers/char/tpm/tpm_ibmvtpm.h
index 51198b137461..252f1cccdfc5 100644
--- a/drivers/char/tpm/tpm_ibmvtpm.h
+++ b/drivers/char/tpm/tpm_ibmvtpm.h
@@ -41,7 +41,8 @@ struct ibmvtpm_dev {
wait_queue_head_t wq;
u16 res_len;
u32 vtpm_version;
- u8 tpm_processing_cmd;
+ u8 tpm_status;
+#define TPM_STATUS_BUSY (1 << 0) /* vtpm is processing a command */
Declare this already in the fix, and just leave the rename here.

You mean the fix patch does not use 'true' anymore but uses the TPM_STATUS_BUSY flag already but the name is still tpm_processing_cmd? And literally only the renaming of this field is done in the 2nd patch?



Otherwise, these look fine.