Re: [greybus-dev] [PATCH v4] staging: greybus: Convert uart.c from IDR to XArray

From: Alex Elder
Date: Mon Aug 30 2021 - 09:20:29 EST


On 8/30/21 7:33 AM, Johan Hovold wrote:
> On Mon, Aug 30, 2021 at 01:16:07PM +0100, Matthew Wilcox wrote:
>> On Mon, Aug 30, 2021 at 01:52:48PM +0200, Johan Hovold wrote:
>>> Whether the API is better is debatable. As I said, almost no drivers use
>>> the new XArray interface, and perhaps partly because the new interface
>>> isn't as intuitive as has been claimed (e.g. xa_load() instead of
>>> ida_find()). And IDR/IDA isn't marked/documented as deprecated as far as
>>> I know.
>>
>> I can't just slap a 'deprecated' attribute on it. That'll cause a
>> storm of warnings. What would you suggest I do to warn people that
>> this interface is deprecated and I would like to remove it?
>
> I'd at least expect a suggestion in the IDR documentation to consider
> using XArray instead.
>
>> Why do you think that idr_find() is more intuitive than xa_load()?
>> The 'find' verb means that you search for something. But it doesn't
>> search for anything; it just returns the pointer at that index.
>> 'find' should return the next non-NULL pointer at-or-above a given
>> index.
>
> We're looking up a minor number which may or may not exist. "Find" (or
> "lookup" or "search") seems to describe this much better than "load"
> (even if that may better reflect the implementation of XArray).
>
> And no, I would not expect a find implementation to return the next
> entry if the requested entry does not exist (and neither does idr_find()
> or radix_tree_lookup())

For what it's worth, I think of "find" as meaning "look up this one
thing, and return it if it's there (or tell me if it's not)." That
is irrespective of underlying implementation.

That verb sometimes might mean something else (like create it if it
doesn't exist, or perhaps "get it or the next available" as suggested)
but I wish we had a slightly different naming convention for those
things.

The XArray interface was designed to better match typical usage of
IDR/IDA, as I understand it. And its name suggests it is modeled
as an array, so "load" seems like a reasonable verb to mean returning
the value associated with an identified entry. (Even though the
"doesn't exist" part doesn't match normal array semantics.)

So I guess I agree in part with both Johan and Matthew on the
meaning
of "load" as used in the XArray interface. Either way, that *is* the
interface at the moment.


I have been offering review feedback on this patch for three reasons:

- First, because I think the intended change does no real harm to the

Greybus code, and in a small way actually simplifies it.

- Because I wanted to encourage Fabio's efforts to be part of the

Linux contributor community.

- Because I suspected that Matthew's long-term intention was to

replace IDR/IDA use with XArray, so this would represent an early

conversion.



The Greybus code is generally good, but that doesn't mean it can't

evolve. It gets very little patch traffic, so I don't consider small

changes like this "useless churn." The Greybus code is held up as
an
example of Linux kernel code that can be safely modified, and I
think
it's actively promoted as a possible source of new developer
tasks
(e.g. for Outreachy).



So aside from the details of the use of XArray, I'd rather we be
more open to changes to the Greybus code.

-Alex

>
> Johan
> _______________________________________________
> greybus-dev mailing list
> greybus-dev@xxxxxxxxxxxxxxxx
> https://lists.linaro.org/mailman/listinfo/greybus-dev
>