Re: [PATCH v3 6/9] clk: qcom: gcc-msm8994: Remove the inexistent GDSC_PCIE

From: Marijn Suijten
Date: Mon Sep 06 2021 - 06:02:06 EST


On 2021-09-04 20:30:10, Konrad Dybcio wrote:
> This GDSC is not present on msm8994.
>
> Signed-off-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxx>
> ---
> [no changes since v2]
>
> drivers/clk/qcom/gcc-msm8994.c | 11 ++---------
> 1 file changed, 2 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/clk/qcom/gcc-msm8994.c b/drivers/clk/qcom/gcc-msm8994.c
> index 98b2fd429629..2ed206ecb60d 100644
> --- a/drivers/clk/qcom/gcc-msm8994.c
> +++ b/drivers/clk/qcom/gcc-msm8994.c
> @@ -2485,14 +2485,6 @@ static struct clk_branch gcc_prng_ahb_clk = {
> },
> };
>
> -static struct gdsc pcie_gdsc = {
> - .gdscr = 0x1e18,
> - .pd = {
> - .name = "pcie",
> - },
> - .pwrsts = PWRSTS_OFF_ON,
> -};
> -
> static struct gdsc pcie_0_gdsc = {
> .gdscr = 0x1ac4,
> .pd = {
> @@ -2682,7 +2674,8 @@ static struct clk_regmap *gcc_msm8994_clocks[] = {
> };
>
> static struct gdsc *gcc_msm8994_gdscs[] = {
> - [PCIE_GDSC] = &pcie_gdsc,
> + /* This GDSC does not exist, but ABI has to remain intact */
> + [PCIE_GDSC] = NULL,

You could possibly leave this out since unspecified array elements are
always initialized to NULL, and place the comment on the #define of
PCIE_GDSC in the dt-bindings header instead?

Alternatively you could rename that define to PCIE_GDSC_DEPRECATED so
that any (out of tree) DT referencing it will be alerted of this change
at compile-time instead of finding a NULL-gdsc at runtime?

> [PCIE_0_GDSC] = &pcie_0_gdsc,
> [PCIE_1_GDSC] = &pcie_1_gdsc,
> [USB30_GDSC] = &usb30_gdsc,
> --
> 2.33.0
>