Re: [PATCH 1/7] arm64: dts: qcom: Introduce support for MSM8998 Sony Yoshino platform

From: Bjorn Andersson
Date: Tue Sep 07 2021 - 09:03:42 EST


On Fri 03 Sep 11:09 PDT 2021, AngeloGioacchino Del Regno wrote:

> This commit introduces support for the Sony Yoshino platform, using
> the MSM8998 SoC, including:
> - Sony Xperia XZ1 (codename Poplar),
> - Sony Xperia XZ1 Compact (codename Lilac),
> - Sony Xperia XZ Premium (codename Maple).
>

Nice!

> diff --git a/arch/arm64/boot/dts/qcom/msm8998-sony-xperia-yoshino.dtsi b/arch/arm64/boot/dts/qcom/msm8998-sony-xperia-yoshino.dtsi
[..]
> + vph_pwr: vph-pwr-regulator {
> + compatible = "regulator-fixed";
> + regulator-name = "vph_pwr";
> + regulator-always-on;
> + regulator-boot-on;
> + };
> +
> + gpio_keys {

Please don't use '_' in node names.

> + compatible = "gpio-keys";
> + input-name = "gpio-keys";
> + label = "Side buttons";
> + #address-cells = <1>;
> + #size-cells = <0>;
> + pinctrl-names = "default";
> + pinctrl-0 = <&vol_down_pin_a>, <&cam_focus_pin_a>,
> + <&cam_snapshot_pin_a>;
> + vol-down {
> + label = "Volume Down";
> + gpios = <&pm8998_gpio 5 GPIO_ACTIVE_LOW>;
> + linux,input-type = <1>;
> + linux,code = <KEY_VOLUMEDOWN>;
> + gpio-key,wakeup;
> + debounce-interval = <15>;
> + };
> +
> + camera-snapshot {
> + label = "Camera Snapshot";
> + gpios = <&pm8998_gpio 7 GPIO_ACTIVE_LOW>;
> + linux,input-type = <1>;
> + linux,code = <KEY_CAMERA>;
> + debounce-interval = <15>;
> + };
> +
> + camera-focus {
> + label = "Camera Focus";
> + gpios = <&pm8998_gpio 8 GPIO_ACTIVE_LOW>;
> + linux,input-type = <1>;
> + linux,code = <KEY_CAMERA_FOCUS>;
> + debounce-interval = <15>;
> + };
> + };
> +
> + gpio_hall_sensor {

Ditto.

> + compatible = "gpio-keys";
> + input-name = "hall-sensors";
> + label = "Hall sensors";
> + #address-cells = <1>;
> + #size-cells = <0>;
> + pinctrl-names = "default";
> + pinctrl-0 = <&hall_sensor0_default>;
> +
> + hall_sensor0 {

And here...

> + label = "Cover Hall Sensor";
> + gpios = <&tlmm 124 GPIO_ACTIVE_LOW>;
> + linux,input-type = <EV_SW>;
> + linux,code = <SW_LID>;
> + gpio-key,wakeup;
> + debounce-interval = <30>;
> + };
> + };
> +
> + reserved-memory {
> + #address-cells = <2>;
> + #size-cells = <2>;
> + ranges;
> +
> + hyp_mem: memory@85800000 {
> + reg = <0x0 0x85800000 0x0 0x3700000>;
> + no-map;
> + };
> +
> + cont_splash_mem: cont-splash-region@9d400000 {

Is there any reason for not just naming this "memory"?

> + reg = <0x0 0x9d400000 0x0 0x2400000>;
> + no-map;
> + };
> +
> + zap_shader_region: gpu@f6400000 {

This is also just "memory" here.

> + compatible = "shared-dma-pool";
> + reg = <0x0 0xf6400000 0x0 0x2000>;
> + no-map;
> + };
> +
[..]
> +&rpm_requests {
> + pm8998-regulators {
> + compatible = "qcom,rpm-pm8998-regulators";
> +
[..]
> + vreg_lvs1a_1p8: lvs1 { };
> + vreg_lvs2a_1p8: lvs2 { };
> +

Blank line.

> + };
> +
> + pmi8998-regulators {
> + compatible = "qcom,rpm-pmi8998-regulators";
> +
> + vdd_bob-supply = <&vph_pwr>;
> +
> + vreg_bob: bob {
> + regulator-min-microvolt = <3312000>;
> + regulator-max-microvolt = <3600000>;
> + };
> + };
> +};
> +
> +&sdhc2 {
> + status = "okay";
> + cd-gpios = <&tlmm 95 GPIO_ACTIVE_HIGH>;
> +
> + vmmc-supply = <&vreg_l21a_2p95>;
> + vqmmc-supply = <&vreg_l13a_2p95>;
> +
> + pinctrl-names = "default", "sleep";
> + pinctrl-0 = <&sdc2_clk_on &sdc2_cmd_on &sdc2_data_on &sdc2_cd_on>;
> + pinctrl-1 = <&sdc2_clk_off &sdc2_cmd_off &sdc2_data_off &sdc2_cd_off>;

How about grouping these various pins as "sdc2_default_state" and
"sdc2_sleep_state"?

> +};
> +
Regards,
Bjorn