[PATCH 0/2] kvm: fix KVM_MAX_VCPU_ID handling

From: Juergen Gross
Date: Mon Sep 13 2021 - 10:01:01 EST


Revert commit 76b4f357d0e7d8f6f00 which was based on wrong reasoning
and rename KVM_MAX_VCPU_ID to KVM_MAX_VCPU_IDS in order to avoid the
same issue in future.

Juergen Gross (2):
x86/kvm: revert commit 76b4f357d0e7d8f6f00
kvm: rename KVM_MAX_VCPU_ID to KVM_MAX_VCPU_IDS

Documentation/virt/kvm/devices/xics.rst | 2 +-
Documentation/virt/kvm/devices/xive.rst | 2 +-
arch/mips/kvm/mips.c | 2 +-
arch/powerpc/include/asm/kvm_book3s.h | 2 +-
arch/powerpc/include/asm/kvm_host.h | 4 ++--
arch/powerpc/kvm/book3s_xive.c | 2 +-
arch/powerpc/kvm/powerpc.c | 2 +-
arch/x86/include/asm/kvm_host.h | 2 +-
arch/x86/kvm/ioapic.c | 2 +-
arch/x86/kvm/ioapic.h | 4 ++--
arch/x86/kvm/x86.c | 2 +-
include/linux/kvm_host.h | 4 ++--
tools/testing/selftests/kvm/kvm_create_max_vcpus.c | 2 +-
virt/kvm/kvm_main.c | 2 +-
14 files changed, 17 insertions(+), 17 deletions(-)

--
2.26.2