Re: [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic

From: Saeed Mahameed
Date: Mon Sep 20 2021 - 17:21:13 EST


On Sun, 2021-09-05 at 09:49 +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features,
> Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or
> similar)
> function arguments due to the risk of them overflowing. This could
> lead
> to values wrapping around and a smaller allocation being made than
> the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, refactor the code a bit to use the purpose specific kcalloc()
> function instead of the argument size * count in the kzalloc()
> function.
>
> [1]
> https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@xxxxxxx>

applied to net-next-mlx5,

Thanks.