Re: [PATCH V2 1/6] dt-bindings: nvmem: add cell-type to nvmem cells

From: Rob Herring
Date: Mon Sep 27 2021 - 16:42:26 EST


On Thu, Sep 23, 2021 at 07:01:04PM +0800, Joakim Zhang wrote:
> From: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxx>
>
> Some of the nvmem providers encode data for certain type of nvmem cell,
> example mac-address is stored in ascii or with delimiter or in reverse order.
>
> This is much specific to vendor, so having a cell-type would allow nvmem
> provider drivers to post-process this before using it.
>
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxx>
> Signed-off-by: Joakim Zhang <qiangqing.zhang@xxxxxxx>
> ---
> Documentation/devicetree/bindings/nvmem/nvmem.yaml | 11 +++++++++++
> include/dt-bindings/nvmem/nvmem.h | 8 ++++++++
> 2 files changed, 19 insertions(+)
> create mode 100644 include/dt-bindings/nvmem/nvmem.h
>
> diff --git a/Documentation/devicetree/bindings/nvmem/nvmem.yaml b/Documentation/devicetree/bindings/nvmem/nvmem.yaml
> index b8dc3d2b6e92..8cf6c7e72b0a 100644
> --- a/Documentation/devicetree/bindings/nvmem/nvmem.yaml
> +++ b/Documentation/devicetree/bindings/nvmem/nvmem.yaml
> @@ -60,6 +60,11 @@ patternProperties:
> - minimum: 1
> description:
> Size in bit within the address range specified by reg.
> + cell-type:
> + $ref: /schemas/types.yaml#/definitions/uint32
> + maxItems: 1
> + description:
> + Type of nvmem, Use defines in dt-bindings/nvmem/nvmem.h.

I don't think magic numbers are the right approach here. Actually, I
don't think we need any DT additions.

Why not just have the consumer side just tell the nvmem provider what
the data is and to translate it. The consumer side already has a name
(e.g. mac-address) which defines what the data is and I think is pretty
standard. If that name is standard, then you could pass it to the nvmem
core. If not, define some kernel internal types to use.

Rob