Re: [PATCH] ACPI: avoid NULL pointer arithmetic

From: Rafael J. Wysocki
Date: Wed Sep 29 2021 - 08:02:11 EST


On Tue, Sep 28, 2021 at 10:39 PM Moore, Robert <robert.moore@xxxxxxxxx> wrote:
>
> I can take this patch as-is, I think. I'll try for the next acpica release later this week.

Thanks!


> -----Original Message-----
> From: Wysocki, Rafael J <rafael.j.wysocki@xxxxxxxxx>
> Sent: Tuesday, September 28, 2021 10:44 AM
> To: Arnd Bergmann <arnd@xxxxxxxxxx>; Moore, Robert <robert.moore@xxxxxxxxx>
> Cc: Arnd Bergmann <arnd@xxxxxxxx>; Nathan Chancellor <nathan@xxxxxxxxxx>; Nick Desaulniers <ndesaulniers@xxxxxxxxxx>; Erik Kaneda <erik.kaneda@xxxxxxxxx>; linux-acpi@xxxxxxxxxxxxxxx; devel@xxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; llvm@xxxxxxxxxxxxxxx; Len Brown <lenb@xxxxxxxxxx>; Rafael J. Wysocki <rafael@xxxxxxxxxx>
> Subject: Re: [PATCH] ACPI: avoid NULL pointer arithmetic
>
> Bob, this is ACPICA material.
>
> Would it be possible to apply this to the upstream from the patch or do you need a PR for this?
>
> On 9/27/2021 2:13 PM, Arnd Bergmann wrote:
> > From: Arnd Bergmann <arnd@xxxxxxxx>
> >
> > There are some very old macros for doing an open-coded offsetof() and
> > cast between pointer and integer in ACPI headers. clang-14 now
> > complains about these:
> >
> > drivers/acpi/acpica/tbfadt.c:86:3: error: performing pointer subtraction with a null pointer has undefined behavior [-Werror,-Wnull-pointer-subtraction]
> > ACPI_FADT_OFFSET(pm_timer_block),
> > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > include/acpi/actbl.h:376:47: note: expanded from macro 'ACPI_FADT_OFFSET'
> > #define ACPI_FADT_OFFSET(f) (u16) ACPI_OFFSET (struct acpi_table_fadt, f)
> >
> > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > include/acpi/actypes.h:511:41: note: expanded from macro 'ACPI_OFFSET'
> > #define ACPI_OFFSET(d, f) ACPI_PTR_DIFF (&(((d *) 0)->f), (void *) 0)
> >
> > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > include/acpi/actypes.h:505:79: note: expanded from macro 'ACPI_PTR_DIFF'
> > #define ACPI_PTR_DIFF(a, b) ((acpi_size) (ACPI_CAST_PTR (u8, (a)) - ACPI_CAST_PTR (u8, (b))))
> >
> > ^ ~~~~~~~~~~~~~~~~~~~~~~~ Convert them to the modern equivalents.
> >
> > Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>
> > ---
> > include/acpi/actypes.h | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/include/acpi/actypes.h b/include/acpi/actypes.h index
> > 92c71dfce0d5..285bc7b73de3 100644
> > --- a/include/acpi/actypes.h
> > +++ b/include/acpi/actypes.h
> > @@ -507,8 +507,8 @@ typedef u64 acpi_integer;
> > /* Pointer/Integer type conversions */
> >
> > #define ACPI_TO_POINTER(i) ACPI_CAST_PTR (void, (acpi_size) (i))
> > -#define ACPI_TO_INTEGER(p) ACPI_PTR_DIFF (p, (void *) 0)
> > -#define ACPI_OFFSET(d, f) ACPI_PTR_DIFF (&(((d *) 0)->f), (void *) 0)
> > +#define ACPI_TO_INTEGER(p) ((uintptr_t)(p))
> > +#define ACPI_OFFSET(d, f) offsetof(d, f)
> > #define ACPI_PHYSADDR_TO_PTR(i) ACPI_TO_POINTER(i)
> > #define ACPI_PTR_TO_PHYSADDR(i) ACPI_TO_INTEGER(i)
> >
>
>