Re: [PATCH 1/6] block: cache bdev in struct file for raw bdev IO

From: Christoph Hellwig
Date: Mon Oct 11 2021 - 04:29:04 EST


On Sat, Oct 09, 2021 at 10:33:17AM -0600, Jens Axboe wrote:
> > +static inline struct block_device *blkdev_get_bdev(struct file *file)
> > +{
> > + return file->private_data;
> > +}
>
> Get rid of this and just use bdev = file->private_data where
> appropriate. Easier to read, we don't need to hide this in a function.

100% agreed.