Re: [PATCH 6/6] block: convert ->bd_inode to container_of()

From: Christoph Hellwig
Date: Mon Oct 11 2021 - 04:34:18 EST


On Sat, Oct 09, 2021 at 01:25:43PM +0100, Pavel Begunkov wrote:
> +static inline struct inode *bdev_file_inode(struct file *file)
> {
> + struct block_device *bdev = blkdev_get_bdev(file);
> +
> + return bdev_get_inode(bdev);
> }

No need for this helper either.

> +static inline struct inode *bdev_get_inode(struct block_device *bdev)
> +{
> + return &container_of(bdev, struct bdev_inode, bdev)->vfs_inode;
> +}

This is rather misnamed, not get anywhere in here.