[PATCH v7 11/21] auxdisplay: ht16k33: Use HT16K33_FB_SIZE in ht16k33_initialize()

From: Geert Uytterhoeven
Date: Tue Oct 12 2021 - 14:51:17 EST


Use the existing HT16K33_FB_SIZE definition instead of open-coding the
same calculation using an hardcoded value.
While at it, restore reverse Christmas tree variable declaration order.

Signed-off-by: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx>
Acked-by: Robin van der Gracht <robin@xxxxxxxxxxx>
---
v7:
- No changes,

v6:
- No changes,

v5:
- No changes,

v4:
- No changes,

v3:
- No changes,

v2:
- Add Acked-by.
---
drivers/auxdisplay/ht16k33.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/auxdisplay/ht16k33.c b/drivers/auxdisplay/ht16k33.c
index ed5808349990782c..fed2f8bd2d27c65b 100644
--- a/drivers/auxdisplay/ht16k33.c
+++ b/drivers/auxdisplay/ht16k33.c
@@ -168,9 +168,9 @@ static void ht16k33_fb_update(struct work_struct *work)

static int ht16k33_initialize(struct ht16k33_priv *priv)
{
+ uint8_t data[HT16K33_FB_SIZE];
uint8_t byte;
int err;
- uint8_t data[HT16K33_MATRIX_LED_MAX_COLS * 2];

/* Clear RAM (8 * 16 bits) */
memset(data, 0, sizeof(data));
--
2.25.1