Re: [PATCH 4/9] x86/alternative: Implement .retpoline_sites support

From: Peter Zijlstra
Date: Wed Oct 13 2021 - 17:48:07 EST


On Wed, Oct 13, 2021 at 02:11:18PM -0700, Josh Poimboeuf wrote:
> On Wed, Oct 13, 2021 at 02:22:21PM +0200, Peter Zijlstra wrote:
> > +#ifdef CONFIG_X86_64
> > +
> > +/*
> > + * CALL/JMP *%\reg
> > + */
> > +static int emit_indirect(int op, int reg, u8 *bytes)
>
> X86_64 is already equivalent to STACK_VALIDATION these days, but might
> as well clarify here where the retpoline_sites dependency comes from by
> changing this to '#ifdef CONFIG_STACK_VALIDATION'.

Yeah, I was contemplating having x86_64 unconditionally select that.
Maybe we should.

Also, I think I've proposed it before, but what about:

s/STACK_VALIDATION/OBJTOOL/

on all that?