[PATCH 2/3] serial: 8250: rename unlock labels

From: Johan Hovold
Date: Fri Oct 15 2021 - 07:14:49 EST


Rename a couple of oddly named labels that are used to unlock before
returning after what they do (rather than after the context they are
used in) to improve readability.

Signed-off-by: Johan Hovold <johan@xxxxxxxxxx>
---
drivers/tty/serial/8250/8250_port.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/tty/serial/8250/8250_port.c b/drivers/tty/serial/8250/8250_port.c
index e4dd82fd7c2a..5775cbff8f6e 100644
--- a/drivers/tty/serial/8250/8250_port.c
+++ b/drivers/tty/serial/8250/8250_port.c
@@ -1338,7 +1338,7 @@ static void autoconfig(struct uart_8250_port *up)
up->tx_loadsz = uart_config[port->type].tx_loadsz;

if (port->type == PORT_UNKNOWN)
- goto out_lock;
+ goto out_unlock;

/*
* Reset the UART.
@@ -1355,7 +1355,7 @@ static void autoconfig(struct uart_8250_port *up)
else
serial_out(up, UART_IER, 0);

-out_lock:
+out_unlock:
spin_unlock_irqrestore(&port->lock, flags);

/*
@@ -2714,12 +2714,12 @@ void serial8250_update_uartclk(struct uart_port *port, unsigned int uartclk)
mutex_lock(&tport->mutex);

if (port->uartclk == uartclk)
- goto out_lock;
+ goto out_unlock;

port->uartclk = uartclk;

if (!tty_port_initialized(tport))
- goto out_lock;
+ goto out_unlock;

termios = &tty->termios;

@@ -2737,7 +2737,7 @@ void serial8250_update_uartclk(struct uart_port *port, unsigned int uartclk)
spin_unlock_irqrestore(&port->lock, flags);
serial8250_rpm_put(up);

-out_lock:
+out_unlock:
mutex_unlock(&tport->mutex);
up_write(&tty->termios_rwsem);
tty_kref_put(tty);
--
2.32.0