Re: [syzbot] BUG: sleeping function called from invalid context in __might_resched

From: Marco Elver
Date: Tue Nov 16 2021 - 05:25:35 EST


On Tue, 16 Nov 2021 at 08:57, Fabio M. De Francesco
<fmdefrancesco@xxxxxxxxx> wrote:
[...]
> I think that this is more readable and comprehensible.
>
> Therefore, if I'm not wrong, Marco's "!preemptible()", that is "if (!
> (preempt_count() == 0 && !irqs_disabled())", might be rewritten to an easier
> to understand "if (preempt_count() || irqs_disabled())".
>
> Am I wrong? Let's test it...

It's right, but why not use preemptible()? The definition of
preemptible() might change and then you'd have to fix the code again.

I actually find (preempt_count() || irqs_disabled()) tells me less of
what your intent here is vs. just writing !preemptible().