Re: [PATCH v3 11/14] drm/rockchip: vop2: Add support for rk3588

From: Sascha Hauer
Date: Tue Dec 05 2023 - 04:30:45 EST


On Thu, Nov 30, 2023 at 08:24:39PM +0800, Andy Yan wrote:
> From: Andy Yan <andy.yan@xxxxxxxxxxxxxx>
>
> VOP2 on rk3588:
>
> Four video ports:
> VP0 Max 4096x2160
> VP1 Max 4096x2160
> VP2 Max 4096x2160
> VP3 Max 2048x1080
>
> 4 4K Cluster windows with AFBC/line RGB and AFBC-only YUV support
> 4 4K Esmart windows with line RGB/YUV support
>
> Signed-off-by: Andy Yan <andy.yan@xxxxxxxxxxxxxx>

With the two nits below feel free to add my:

Reviewed-by: Sascha Hauer <s.hauer@xxxxxxxxxxxxxx>

Thanks for working on this.

> diff --git a/drivers/gpu/drm/rockchip/rockchip_drm_vop2.h b/drivers/gpu/drm/rockchip/rockchip_drm_vop2.h
> index 8d7ff52523fb..8b16031eda52 100644
> --- a/drivers/gpu/drm/rockchip/rockchip_drm_vop2.h
> +++ b/drivers/gpu/drm/rockchip/rockchip_drm_vop2.h
> @@ -13,9 +13,16 @@
>
> #define VOP_FEATURE_OUTPUT_10BIT BIT(0)

You could rename this to include "VP" for Video Port so it's not so
easily mixed up with the defines below.

>
> +#define VOP2_FEATURE_HAS_SYS_GRF BIT(0)
> +#define VOP2_FEATURE_HAS_VO0_GRF BIT(1)
> +#define VOP2_FEATURE_HAS_VO1_GRF BIT(2)
> +#define VOP2_FEATURE_HAS_VOP_GRF BIT(3)
> +#define VOP2_FEATURE_HAS_SYS_PMU BIT(5)

Should be BIT(4)

Sascha

--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |