Re: [PATCH v3 09/11] PCI: imx: Consolidate redundant if-checks

From: Manivannan Sadhasivam
Date: Sat Apr 27 2024 - 07:38:36 EST


On Tue, Apr 02, 2024 at 10:33:45AM -0400, Frank Li wrote:
> Consolidated redundant if-checks pertaining to imx_pcie->phy. Instead of
> two separate checks, merged them into one to improve code readability.
>
> if (imx_pcie->phy) {
> ... code 1
> }
>
> if (imx_pcie->phy) {
> ... code 2
> }
>
> Merge into one if block.
>
> if (imx_pcie->phy) {
> ... code 1
> ... code 2
> }
>
> Signed-off-by: Frank Li <Frank.Li@xxxxxxx>

Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxx>

- Mani

> ---
> drivers/pci/controller/dwc/pcie-imx.c | 2 --
> 1 file changed, 2 deletions(-)
>
> diff --git a/drivers/pci/controller/dwc/pcie-imx.c b/drivers/pci/controller/dwc/pcie-imx.c
> index 653d8e8ee1abc..378808262d16b 100644
> --- a/drivers/pci/controller/dwc/pcie-imx.c
> +++ b/drivers/pci/controller/dwc/pcie-imx.c
> @@ -1103,9 +1103,7 @@ static int imx_pcie_host_init(struct dw_pcie_rp *pp)
> dev_err(dev, "pcie PHY power up failed\n");
> goto err_clk_disable;
> }
> - }
>
> - if (imx_pcie->phy) {
> ret = phy_power_on(imx_pcie->phy);
> if (ret) {
> dev_err(dev, "waiting for PHY ready timeout!\n");
>
> --
> 2.34.1
>

--
மணிவண்ணன் சதாசிவம்