Re: [PATCH] mtd: spi-nor: replace unnecessary div64_u64() with div_u64()

From: Pratyush Yadav
Date: Mon Apr 29 2024 - 09:27:53 EST


Hi,

On Mon, Apr 29 2024, Michael Walle wrote:

> Both occurences of div64_u64() just have a u8 or u32 divisor. Use
> div_u64() instead.

Does this improve performance or is this only for correctness?

Patch LGTM otherwise.

Reviewed-by: Pratyush Yadav <pratyush@xxxxxxxxxx>

BTW, I also noticed that there is a do_div() call in spi_nor_write()
that also uses a u64 dividend and u32 divisor. I was wondering why it
uses do_div() and not div_u64() (I am not sure what the difference
between the two is) but I suppose it doesn't matter much since your
spring cleaning series will delete that code anyway.

--
Regards,
Pratyush Yadav