Re: getty breaks with linux-1.3.3

Ed Saffle (
Sun, 25 Jun 1995 00:10:11 -0400

snowcat@gd.cs.CSUFresno.EDU (Snow Cat) writes:
> Subject: getty breaks with linux-1.3.3
> I just upgraded to Linux 1.3.3 with H.J's ELF patches and the system booted
> fine until getty. After getty ran, it got stuck without any output :( I was
> using agetty (linked and ELF), so I switched and tried getty-ps (linked as
> a.out). This time I got login prompt, but when I typed enough things to get to
> the end of the screen, it won't scroll.
> Since all getty's won't work, I suspect that the problem is with 1.3.3 console
> driver. In particular I have an impression that agetty is using ioctl's like
> TCSETA instead of tcsetattr. Can anyone debug this?

That's sort of strange to me. I have recently upgraded to 1.3.3 myself
and also with the ELF patches. However my getty seems to work fine. I
did originally have some trouble caused by my bash seg faulting after the
upgrade. Which means that my rc scripts did not work. :)
All I did was recompile bash and it worked fine thereafter. I also noted
that my binary for the "file" command had the same troubles but was fine
after recompiling. I am using getty-ps and it seems to be working just

Ed Saffle