Re: Kernel math prob? or other problem? (fwd)

Mathew G. Monroe (
Wed, 28 Jun 1995 04:04:46 -0400 (EDT)

> I only slightly suspect this to be a kernel related issue, but I think
> it is likely enough to post to the kernel list. At least you can tell
> me if it is relevant.
> I run a web server that generates a lot of traffic, and I use the
> 'wwwstat' program, which is a perl script that parses the ncsa httpd
> logfiles to summarize.
> Every time I attempt to run the program against my data, it gets about
> 1/3 of the way through, and aborts with a "Floating Point Exception".
> Now, is that fp exception at the system level? Or is it Perl itself
> telling me?
> This is running on a 486dx4/100, 16 MB Ram+32M swap, and we've gotten
> the same results with various kernels 1.2.x (up to .8) I'm building
> 1.2.11 right now to try it.
> For the purpose of sanity checking, I ran the same data, same script,
> same perl version on a sun sparc 5, 16 MB Ram+32M swap, and the script
> completed successfully.
> Thanks for any help you can give me.
> ------------------------+----------------------------------------------
> James L. McGill | Professional Internet Consulting [PICnet]
> Systems Administrator | 12801 N. Central Expressway, Suite 1518
> PICnet NOC Staff | Dallas, Texas 75243
> <> | -=[ vox: 214-789-0456 fax: 214-789-0460 ]=-
> ------------------------+----------------------------------------------

This is actually a program error, at least it appears to be. SunOS provides
the matherr fucntion, Linux does not. The matherr function catchs floating
point exceptions. From what I can tell it is not part of POSIX, so Linux
doesn't support it. I would guess you are getting floating point exceptions
on both platforms, just the SunOS version hides it. Either the program or
perl installed a copy of matherr, so you dont get to find out about it. Of
course I could always be wrong.