Problem with GCC 2.7.0

Raymond W. Lucke IV (
Wed, 28 Jun 1995 08:26:56 -0700 (PDT)

When I tried to compile Linux under it, the whole compile worked great
until it got to this point:

ld -qmagic -Ttext 0xfffe0 arch/i386/kernel/head.o init/main.o
init/version.o \
arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o
mm/mm.o fs/fs.o net/net.o ipc/ipc.o \
fs/filesystems.a \
drivers/block/block.a drivers/char/char.a drivers/net/net.a
drivers/scsi/scsi.a drivers/sound/sound.a \
/usr/src/linux-1.2.11/lib/lib.a -o vmlinux
ld: warning: cannot find entry symbol _start; defaulting to 000fffe0
arch/i386/kernel/head.o(.text+0x18): undefined reference to `__edata'
arch/i386/kernel/head.o(.text+0x1d): undefined reference to `__end'
arch/i386/kernel/head.o(.text+0x7f): undefined reference to `_x86'
arch/i386/kernel/head.o(.text+0xa3): undefined reference to `_x86'

Then all the errors ^^^ occurred. Every routine in every file (that I
could see) showed up as being undefined. I have done no hacking of this
kernel (yet). I have the newest versions of libc,, binutils, etc. I
would appreciate any help anyone might have.

Raymond W. Lucke IV

PS: I did compile a couple programs before it with 2.7.0, they worked fine.