aha1542 kernel problems

Mike Connors (connorsm@ficus.cs.ucla.edu)
Tue, 16 Jul 1996 15:01:32 -0700


I'm trying to get a working elf kernel on a couple of Dell 4560/XE
Pentium machines that have Adaptec 1542 and Pro Audio Spectrum-16
SCSI cards in them.

They once had working kernels in them, but I'm not sure if the guy who
worked here before me modified his own kernel, or if it used to work
in earlier versions of the slackware kernel.

When I try to load the kernel I configured, I get the following error:

aha1542.c: interrupt received, but no mail.

This error was produced from line 423 of the scsi driver aha1542.c. I
didn't think looking over the code would do me any good since I know
little about scsi and writing drivers, so I tried other boot disks from
slackware and redhat. The errors I got from them are below.

I am totally lost at this point and any help would be appreciated.

Thanks in advance,
Mike Connors

These are the errors that I get when I try to boot using the scsinet1 boot
disk from slackware 3.0

Verstion 3.10
[ some cut out]

BusLogic SCSI: buslogic_out: failed(4) Buslogic SCSI: buslogic_stat status=39 intrflags 84
BusLogic SCSI: setup_mailboxes: failed setting up mailboxes.
aha1542_in failed(3): Unable to determine Adaptec DMA priority. Disabling board
No BIOS32 extensions presnet. This release depends on it. Sorry.
scsi : 0 hosts.
scsi : detected total.
Memory: 63724k/65536k available (804k kernel code, 384k reserved, 624k data)
[unrelated stuff cut out]
Linux version 1.2.13 (root@bigkitty) (gcc version 2.7.0) #1 ...
VFS: Insert ramdisk floppy and press ENTER

( of course, after loading the ram disk, you can't mount /dev/sda4 )

I got similiar errors when trying to use Redhat's boot0022.img disk.
I then tried the aha-pas.ker kernel from redhat. It seems to load ok,
but then panics when it tries to mount the root file system. Here is the
output from when the redhat kernel was loading:

Verstion 3.10
[ some cut out]

Configuring Adaptec at IO:330, IRQ 11, DMA priority 5
scsi1: interrupts not enabled. for better interactive performance,
scsi1: please jumper the board for a free IRQ
scsi1: at 0x03888 interrupts disabled options CAN_QUEUE=32 CMD_PER_LUN=2 release=3 generic options AUTOPROBE_IRQ AUTOSENSE PSUEDO DMA UNSAFE generic release=6
scsi0 : Adaptec 1542
scsi1 : Pro Audio Spectrum-16 SCSI
scsi : 2 hosts.
Vendor: DEC Model: DSP3105S Rev: 386C
Type: Direct-Access ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, id 0, lun 0
Vendor: SONY Model: CD-ROM CDU-541 Rev: 4.3a
Type: CD-ROM ANSI SCSI revision 02
Detected scsi CD-ROM sr0 at scsi0, id 0, lun 0
scsi : detected 1 SCSI cdrom 1 SCSI disk total.
SCSI Hardware sector size is 512 bytes on device sda
Memory ... [unrelated stuff was cut out]
Linux version 1.2.13 (root@wylie.redhat.com) (gcc version 2.7.2) #2 Wed ...
Partition check:
sda: sda1 sda3 sda4
Kernle panic: VFS: Unable to mount root fs on 03:01