login doesnt work on dialup..

D. Chiodo (djc@microwave.com)
Tue, 19 Nov 1996 12:28:43 -0500 (EST)

Ok.. I previously posted that I was using a setup with mgetty, kernel
2.0.24, slackware96, shadow, etc.., with the following symptoms:

mgetty answers the line, displays its prompts.

I can enter userid..

login is exec'ed (I can see it in ps -ax on another session) but never
outputs anything. I tried entering the password blind (which does echo),
and it still does nothing.

I _CAN_ telnet into the box, and the same exact /bin/login works fine.

If I set an empty password for a user, I _CAN_ login as that user on the
dialup port..


However, I have now noted that if I then try to "su" on that port (logged in as the passwordless user), it just sits there.. (Although I _can_ break it with ^C)..

su _DOES_ work correctly if I telnet in.

The only thing I can think of that might make sense is somehow when "su" or "login" try to set "no-echo" mode on the tty they are hanging..

"stty -echo" works fine tho.. (both on the tty and the pty)

I've been hammering my head on this for almost a week now, and it was supposed to be online a couple days ago.. I would VERY much appreciate any help or suggestions anyone could offer.

I just tried updating to libc 5.4.7 and ld.so-1.7.14 - no change..