Re: login doesnt work on dialup..

D. Chiodo (
Wed, 20 Nov 1996 09:54:42 -0500 (EST)

Ok, after poking around in the bowels of the shadow suite I have some
more, VERY specific information.


The follwing code in getpass.c, in the getpass() function:

* if /dev/tty can't be opened, getpass() needs to read
* from stdin instead.
syslog(LOG_WARN, "TRACE gp1");

if ((fp = fopen ("/dev/tty", "r")) == 0) {
syslog(LOG_WARN, "TRACE gp2");
fp = stdin;
setbuf (fp, (char *) 0);
} else {
syslog(LOG_WARN, "TRACE gp3");
tty_opened = 1;
syslog(LOG_WARN, "TRACE gp4");


It gets to "gp1", but never to gp2 *OR* gp3 (or any further). The fopen() never returns.

This is on a Comtrol Rocketport board, which works fine otherwise. If getpass() is not called (I log in as a user without password), there is no problem.

Any ideas? A similar setup on another machine (with a 2.0.18 kernel) works fine. This machine (2.0.25, previously 2.0.24) is the only one with a problem.

On Tue, 19 Nov 1996, D. Chiodo wrote:

> Date: Tue, 19 Nov 1996 12:28:43 -0500 (EST) > From: "D. Chiodo" <> > To:, > Subject: login doesnt work on dialup.. > > > > Ok.. I previously posted that I was using a setup with mgetty, kernel > 2.0.24, slackware96, shadow, etc.., with the following symptoms: > > mgetty answers the line, displays its prompts. > > I can enter userid.. > > login is exec'ed (I can see it in ps -ax on another session) but never > outputs anything. I tried entering the password blind (which does echo), > and it still does nothing. > > I _CAN_ telnet into the box, and the same exact /bin/login works fine. > > If I set an empty password for a user, I _CAN_ login as that user on the > dialup port.. > > --- > > However, I have now noted that if I then try to "su" on that port (logged > in as the passwordless user), it just sits there.. (Although I _can_ break > it with ^C).. > > su _DOES_ work correctly if I telnet in. > > The only thing I can think of that might make sense is somehow when "su" > or "login" try to set "no-echo" mode on the tty they are hanging.. > > "stty -echo" works fine tho.. (both on the tty and the pty) > > I've been hammering my head on this for almost a week now, and it was > supposed to be online a couple days ago.. I would VERY much appreciate any > help or suggestions anyone could offer. > > I just tried updating to libc 5.4.7 and - no change.. > >