Re: IRQ 2,9

Derrik Pates (dpates@Cavern.NMSU.Edu)
Tue, 11 Feb 1997 22:21:02 -0700 (MST)

On Tue, 11 Feb 1997, Charlie Ross wrote:

> I recently tried to add a new card to my computer, and needed an IRQ...
> heres what happened:

OK, sounds good.

> 2: uhhh somthing wierd....videoish
[snip snip]
> 9: uhhh somthing wierd...videoish

IRQ's 2 and 9 cascade the IRQs from IRQ controller 2 into controller 1.
You can use IRQ 9 - I've done it successfully with an assortment of cards
on my box.

> anyway.. as you can see I'mm preety well full and out of irq's except for 2
> and 9... which I think are video related...

See above.

> The thing I am adding NEEDS to be on irq 12 (ps2 style mouse port) so I
> seed to move ms scsi card... it can only take 9,10,11 or 12 if i move it to
> 9 linux cant find it... which is wierd... B/C win95 can.
> I get the following errors:
> Feb 11 22:40:26 spiff linux: aha152x0: vital data: PORTBASE=0x340, IRQ=9,
> SCSI ID=7, reconnect=enabled, parity=enabled, synchronous=disabled,
> delay=100, extended translation=disabled
> Feb 11 22:40:26 spiff linux: aha152x: trying software interrupt, lost.
> Feb 11 22:40:27 spiff linux: aha152x: IRQ 9 possibly wrong. Please verify.
> Feb 11 22:40:27 spiff linux: scsi0 : Adaptec 152x SCSI driver; $Revision:
> 1.7 $
> Feb 11 22:40:27 spiff linux: scsi : 1 host.
[snipped a lot of messages]
> Feb 11 22:40:27 spiff linux: scsi : detected total.

Plug and pray system, I take it? Probably the SCSI card is plug-and-play,
and is getting assigned to some other IRQ. Then, when you tell it IRQ9
explicitly, it tries and fails to communicate over that IRQ. might wanna
check to see if there are manual DIPs or jumpers on the card that you can

> i tried moving my net card to 2 (the only other IRQ i was unsure of) and
> then moving my SCSI card to 11.... so NOTHING was on 9.... then when I
> rebooted linux it began to scream bloody murder about somthing on IRQ 9
> (yep 9 not a typo) the message was "Interupt 9: unknown device!" repeated
> forever. (or somthing to that effect... I was unable to do a copy/paste of
> it bc my system was unusable in that state)

You can NOT use IRQ 2 - the cascade controller lives there. That will
DEFINITELY make your system flip.

> Whats the deal with IRQ 2 and 9? can I use either one of them?
> and if not... I wouldnt suppose theres some sly way to "share" irq's or
> some even more sly way to add more (I know that this is impossible given
> the arcitecture of an intel chip... but I'll ask anyway)

IRQ 9 is the one to use. Try hardware switches on that SCSI card, cuz it
should work.


Derrik Pates

"What'll you two lovable plush toys have?"
"How 'bout a root beer popsicle and an Orange Julius? What about you,
"Dishwater! And put it in a dirty glass!"
-Sam & Max
"Fair Wind to Java"