Re: at halt/reboot: umount: device /dev/hda5 busy (=/usr)

Bas Mevissen (
Wed, 5 Mar 1997 09:14:34 +0100 (MET)

Eirik Fuller wrote:
: I recently made an interesting discovery. I was trying to umount /usr
: from a rescue disk, and got the same error (device busy). I was able to
: get past that with "LD_LIBRARY_PATH=/lib umount /usr", i.e. telling the
: dynamic linker to ignore /usr prevented /usr from being busy during the
: umount. Later, I noticed that I was able to umount /usr even without
: specifying LD_LIBRARY_PATH, after running ldconfig with /usr unmounted.
: I'm not entirely sure of this, but I think it might be possible for the
: dynamic linker to perform unnecessary directory searches if there is
: something wrong with /etc/; it might be worth your while to
: run ldconfig, to see whether that clears up the problem.
I tried ldconfig. After upgrading and libc, I ran ldconfig.

I also found that was causing some problems. I put the old
/lib/ back. I then could umount /usr in single user mode, but
that only worked once ! Afterwards I didn't succeed in getting it back. I
changed something, but I don't know what anymore.

: If the problem persists, you might want to install lsof, and run that
: just before the umount command that fails; "lsof /usr" should show
: everything that's preventing /usr from unmounting. In rare
: circumstances it can fail, but it catches most obstacles.

That's the program I was looking for. Do you know where I can find it ?
: If there isn't some process still running (you could run ps also, though
: that won't be as informative) which is keeping /usr mounted, the other
: possibility I can think of is a mount point below /usr which didn't get
: unmounted. One way to test that is to compare /etc/mtab against
: /proc/mounts at the time of the problem (assuming that /proc is still
: mounted then).

ps didn't help me any further.

Thank you for your reply.


PGP: Finger for PGP public key, KeyID 3B896721 
WWW: (Also PGP public key)