Upgrade problems: new libc, ld.so, mount causing problems

Bas Mevissen (sgm@stack.nl)
Thu, 6 Mar 1997 10:34:29 +0100 (MET)

Hello all,

I have a few problems with the development kernels.

I use RedHat 4.1 on a 486DX-133 with the 2.0.29 kernel.
RH 4.1 comes with libc-5.3.12 and ld.so 1.7.14
This all worked very stable.

Then I wanted to try 2.1.26.

First I tried to just upgrade the kernel. That worked. I didn't see any
troubles, but I didn't use it very much, so there can be problems.

Then I upgraded the following packages according to Documentation/Changes:

- Kernel modules modutils-2.1.23
- Binutils ( is out now )
- Linux C Library 5.4.23
- Dynamic Linker (ld.so) 1.8.9 and 1.8.10 later on
- Linux C++ Library
- SysVinit 2.69 from ftp.redhat.com; downgraded later on
- Mount 2.5p

Then I recompiled the kernel and modules. I compiles SMB support as a module
and enabled Win95 bug work-around.

Then I got that umount problem I mailed about before.

Then I tried to smbmount a volume from a computer running Windoze 95.
The mount succeeds, the module is loaded, but after a few seconds, I no
longer get any byte.

My solution: put everything back in place (that is, standard RedHat 4.1,
with kernel 2.0.29) and everything worked again.

Now the question:

Does someone use 2.1.xx and SMB on a Windoze 95 box WITHOUT problems ?
Can someone tell me what I should do to get the whole thing running like a
charm ? That should be possible though ?

I found that some of the problems are due to ld.so's library
libdl.so.1.8.{9|10}, because downgrading it fixed the umount problem.
Unfortunately there are dependancies: there is something with the
libc-mount-ld.so combination, but I can't find what !

Any hints are very welcome,



E-mail: sgm@stack.nl, S.G.A.H.Mevissen@stud.tue.nl
PGP: Finger sgm@toad.stack.nl for PGP public key, KeyID 3B896721 
WWW: www.stack.nl/~sgm (Also PGP public key)