ping to broadcast address: permission denied?

Paul Slootman (
Fri, 7 Mar 1997 13:02:25 +0100 (MET) wrote:
>I have fetched, compiled, and made available Trygve Gudmundsen's
>Linux-modified version of Eric Wassenaar's excellent "ping" program. It is
>all sitting on on in "/pub/net/wassenaar-ping". As Trygve
>mentioned his site was about to be down for 5 days I figured this could be
>a useful service 8^)

I've picked up this version, compiled it, but it still doesn't
do what I'd hoped (I had already expected it wasn't a ping code

The problem is this:

I'm on a subnetted B-class network (, netmask
This all works fine, however I cannot ping the broadcast address (which
is Ping says:

# ./ping
PING 56 data bytes
sendto: Permission denied
no reply from within 1 sec
sendto: Permission denied

---- PING Statistics ----
2 packets transmitted, 0 packets received, 100% packet loss

This works perfectly from a Solaris 2.5 system on the same network...
I tried tracing this into the kernel, but at a certain point I get
lost. It's definitely sendto() that returns -1 EACCES, according to

Same thing when pinging the loopback broadcast address,
so it doesn't look like it's a subnetting problem.

Anyone know what the problem is? Even better, what the solution is?
Vanilla 2.0.29.

Paul Slootman

Murphy Software, Enschede, The Netherlands | Support Randal Schwartz!
work: /  | Email
home:                 | for info.