RE: Trouble booting past "LI" with large SCSI

James Mastros (
Tue, 1 Apr 1997 20:22:44 -0500

From: Illuminati Primus[]
Sent: Monday, March 31, 1997 8:48 PM
Subject: Trouble booting past "LI" with large SCSI

Hello, I'm sorry about this being a little off topic, but I've tried
almost everything.. And now its almost 2am.. doh.. And probably everyone
knows how to do this right except me.. Well anyway..
I have a machine with one large (2 gig) SCSI drive that I just recently
installed linux on (by mostly copying everything over the network)..
I read the docs about how you have to set up a small partition under the
first 1024 cylinders to boot off of, and I did that. I set aside 10 megs
for that purpose under /boot (and I copied all the lilo stuff into it). I
installed lilo with the target pointing to /dev/sda (the MBR). However,
after rebooting it pops up with the two letters "LI".
How do I fix this?
Reading the LILO README, it says:
LI The first stage boot loader was able to load the second stage boot
loader, but has failed to execute it. This can either be caused by a
geometry mismatch or by moving /boot/boot.b without running the map

I have reinstalled lilo into the MBR several times now after moving it to
the small 10 meg partition on sda1, so it must not be caused by being
unable to find boot.b.. So I guess this means its a geometry mismatch? If
so, what causes this? How do I fix it? If it makes any difference, the
computer is an HP Vectra.. might the BIOS be disguising the geometry?
Something else that might (?) be relevant: Once I tried using a regular
MBR with the active partition set to sda1 (fdisk /mbr), but that results a
message similar to "cannot find operating system".. Why not?
Any help is sincerely appreciatted..
-Vermont Rutherfoord

For example porposes:
Dos is on /dev/hda1
Linux is on /dev/hda2 (kernel at /vmlinuz)

1> From linux fdisk, set the bootable partition to part#1
2> From DOS, do fdisk /MBR
3> A normal power-up should get you to DOS
4> From linux, install LILO *on /dev/hda2*
5> Set part#2 bootable, part#1 unbootable
6> Normal power-up should goto a LILO menu
(Trivial to setup the lilo.conf file.)

--- James Mastros