Re: 2.1.32 still won't boot

Gerard Roudier (
Mon, 7 Apr 1997 20:27:27 +0000 (GMT)

On 6 Apr 1997, Linus Torvalds wrote:

> In article <>,
> Neil Moore <> wrote:
> >
> >I recently (i.e. about 30 minutes ago) tried upgrading from 2.1.29
> >to 2.1.32. After I get the "Now booting the kernel." message,
> >the console stops. I can still hear hard drive movement, and
> >apparently *something* is happening -- if I let it go on long
> >enough before I hit reset, the root partitions end up being
> >marked as non-clean (forcing fsck on the next boot). Nothing
> >goes to syslog though. It looks like it dies before init gets
> >run, but I can't be sure.
> Have you enabled CONFIG_VT and CONFIG_VT_CONSOLE (or whatever they are
> called). They are new options, and if you don't enable them you won't
> have much in the way of a screen driver ;)
> >2.1.31 had the same problem on my machine.
> That would match with CONFIG_VT - it was added in 2.1.31. The kernel
> might well be running and working happily, you just don't see any output..

I tried this, (disabling CONFIG_VT and CONFIG_VT_CONSOLE), just to see
what will happen and I did not see any output, as expected.
Then, I pressed Control+Alt+Del to see what will happen.
Nothing seems to happen, but I heared some disk activity.
I wait for about 1 minute and decided to press the RESET button.

My system did not want to reboot. A message like "cannot open console" let
me think that the root partition was trashed.
Fortunately, it is a root partition for testing that stays on an IDE disk. :)

'fsck' said '/' was not a directory and linked all the directory
under '/' to "lost+found". So I could fix the problem manually (thanks to

I never got such a problem with Linux. My opinion is that it is a
software bug. Can you try the same test on your personnal system? :-)