Strange problems on my Linux server

Gregor Longariva (
Fri, 2 May 1997 02:47:27 +0200

I don't know where's the problem, so I don't know who to contact.

I have a linux server running on a 486 with 8MB (16MB swap) an
Kernel 2.0.30. I use this machine to log me into my University
via ISDN. On this machine I use IP masquerading to map my IP on
the University into my internal network (currently only one
computer :-).
When I use the connections via IP masquerading and ISDN on my
workstation under WindowsNT and Win95 there's no problem.
But every time when I run a network-application (eg. netscape
or ftp) under Linux (2.0.30) and try to connect any site outside
my network, the server gives the following error message, dies
and I must turn off the power.
Here's the message:

kernel panic: skpush under: 001b9fbc:4
in swapper task - not syncing

The strange thing is, that everything works fine when I run ANY
network/internet application under Windows (I have not other

Again, here's my configuration:

----------- ----------------- -------------------
Internet | ISDN | 2.0.30 | ethernet | 2.0.30 |
(University|------| IP masquerading |----------| pentium 32mb/64mb |
| | i486 8mb/16mb | | (netscape, ftp ...|
----------- ----------------- -------------------
the strange problems

Another thing: this problem happened with all 2.0.x kernels (I did
not try the older (1.2.x or 1.3.x) or hacker (2.1.x) ones)
Please help me, I've tryed any kind of Kernel configurations on both
Linux boxes. And I WANT to use the network applications under Linux
and erase definitively Windows... ;-)
Any idea?
Thanx and greetings

Gregor Longariva <>