Re: VFAT Filesystem Unrecognized

Joe Pranevich (
Tue, 01 Jul 1997 19:41:28 -0400

B. James Phillippe wrote:
> On Mon, 30 Jun 1997, SethMeister G. wrote:
> > Hi there,
> >
> >
> > I have had this problem for a long time now, but I am just writing
> > about it now (because I am fed up with it :)) -- I have a vfat filesystem
> > that works just fine in windows 95, but does not want to work in linux.
> > The error I get is the syslog is:
> >
> > [MS-DOS FS Rel. 12,FAT 16,check=n,conv=b,uid=0,gid=0,umask=077]
> > [me=0xf8,cs=16,#f=2,fs=1,fl=168,ds=337,de=512,data=369,se=0,ts=717633,ls=512]
> > Transaction block size = 512
> > VFS: Can't find a valid MSDOS filesystem on dev 03:05.
> Is the VFAT partition a FAT32 partition? Windows fdisk will tell you
> that. I just ran into that problem yesterday. I needed to copy one
> Windows 95 computer to a new hard drive, and there is no way to do it
> under 95 so I stuck the drive in my Linux box, mounted it VFAT and made a
> tar of it. Then I tried mounting the replacement disk as VFAT but it
> wouldn't mount. I looked at the drive using Windows fdisk and saw that
> when I formatted it under Windows, it had formatted the drive using FAT32.
> I had to reformat it using a different Windows 95 (??) to get it to format

You can do both on the same copy of Windows 95, but it's weird.

The FAT32 aware fdisk give you a cryptic prompt when it starts, I don't
know the exact wording but it's not 100% clear. Answer yes to this
prompt and any new drives you create will be FAT32, answer no and
they'll be FAT16. (FAT12 is still used on really small partitions, I

Just remove the partition, exit fdisk, answer the prompt as NO, and
create a new one as FAT16. The 'format' command will check to see the
partition type and format it accordingly.

There WILL be an official FAT16 -> FAT32 conversion utility from
Microsoft, but it won't ship until Winhell 97. (Which might not get here
until 98 :) )

> the drive using FAT16. Then it mounted and I unpacked my tar. It worked
> perfectly as it should have using FAT16, but I never did get it mount when
> it was FAT32. I looked through the mount otions for FAT and saw the
> fat=12/16 option, but there was no fat=32 (I tried it anyway and it didn't
> work).
> Is there a reason that FAT32 doesn't work with the VFAT fstype, other than
> that support hasn't been added yet?

I thought (maybe incorrectly) that FAT32 has some sort of internal VFAT
that doesn't make it compatible with VFAT for 16 and 12 bit systems.
Both the 16 and 12 bit versions of FAT are nearly identical and all the
structs are laid out the same. Looking at the VFAT struct included in
the documentation, it wouldn't support FAT32 out of the box.

I don't have the FAT32 structure to look at, so I really don't know if
it has built-in VFAT, or not.

My GUESS is that if VFAT support would work for FAT32, it'll wait until
FAT32 is officially in the kernel. (It might be in the 2.1.x series... I
didn't bother checking that, either.)

ps I've been told that a newer version of VFAT has not yet been put in
the kernel, you might want to find the maintainer's site and check that
out. Maybe it would fix the problem.

> thanks,
> -bp
> --
> B. James Phillippe Seattle Software Labs, Inc
> Network Administrator Phone: (206) 521-8346
> NIC Handle: BJP4 Fax: (206) 521-8340

Joe Pranevich